JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#1015 cant save swf file
Author: user malik123
Date created:
Type: bug
Visibility: Everybody
Assigned to:
State: closed Help

> What steps will reproduce the problem? i was using version 1.6.7 and it can save swf after changing script but i am unable to change a domain with it like this line public static var fileServerItems:String = "http://somedomain.com/"; not i want to edit domain with my own domain because old one is dead 6.1 is unable to open swf file i am using 5.0 it can open file.. change successfully but when i save it gives swf.bmp file in output no matter whatever i change even a string only its giving same error > What is the expected output? What do you see instead? i can only see swf.bmp file with no size > What version of the product are you using? Is it "nightly build"? Which operating system do you have? i have used multiple versions old new but same problem only 1.6.7 or older can open and save file but cant change so much with it > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you. main.swf is attached please help me...
Downloadmain.swf (3,168 KiB)
developer
bmp? are you sure? isn't it tmp?
user
oo yes my bad its tmp...
developer
I was able to open your file in 6.0.1. Is there any error message? Sorry, we won't fix the problem in vresion 5.0, since we don't have a branch for that old version, we are fixin the bugs only in latest version.
user
6.0.1 nightly build can open swf but cant save it same output 0 kb swf.tmp ..
developer
Ok, first you said, that "6.1 is unable to open swf file"... we don't have version 6.1, so I tried 6.0.1, but it opend the file.. Now you said that it opens the file, but it saves 0 bytes temporary file only. Sorry, but i can't reprodue the problem, for me the swf is saved. So pleas specify all the steps to repoduce the problem. Please try the latest nightly build, too. Is there any error message in FFDec?
developer
I close this issue due to inactivity. Please create new issue if problem persists.
State: new→closed