JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#1041 FFDec (java) package names in decompiled AS code
Author: developer honfika
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: AS1/2Decompilation
State: closed Help

> What steps will reproduce the problem? Open for example: wOne_Designer_secure.swf\scripts\__Packages\External\CDataTransport.as > What is the expected output? What do you see instead? Current: this.cbObject.mObject.§com.jpexs.decompiler.flash.action.model.GetMemberActionItem§(this .getBytesLoaded() / this.getBytesTotal()); Expected: Not sure, but something without the full java name of GetMemberActionItem. The problem seems to be only in AS1/2 There are mcuh more similar issues in the swfs. Using the following classes: com.jpexs.decompiler.flash.action.model.GetMemberActionItem com.jpexs.decompiler.flash.action.model.operations.AddActionItem com.jpexs.decompiler.graph.model.TernarOpItem After the fix I'll test all of them again.
developer
AddAction is for example: Push 0.0 register1 "get" "p" GetVariable Add2 CallMethod Return It creates the method name dynamically.
developer
I fixed it partially. Please check this commit: https://github.com/jindrapetrik/jpexs-decompiler/commit/599f75a699bb7c3e185e202438c3bb7968 2edfb5 now it decompiles as: this[this.cbObject.fSuccess].call(...); and: this["get" + p].call(...); I haven't tried it, i hope this is the correct format... (I fount it on the internet:)) I'll find similar issues, and I'll let you know if there is any.
State: new→upgraded
developer
I didn't find any new similar problem, so I close this issue now.
State: upgraded→closed