: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#1154 The Program Won't Start at All
Author: user Mettaton
Date created:
Type: bug
Visibility: Everybody
Assigned to:
State: closed Help

So there is a recurring problem I have with this decompiler, which is the program not opening at all. I have tried opening the .jar, I have tried the .bat and I have tried the .exe. None seem to open the program, and I even tried: - Uninstalling and reinstalling the decompiler. - Restarting the computer. - Uninstalling and updating java (It's up-to-date) - Running FFDec from cmd. When opening the .exe, it showed the logo followed by nothing else. I had also opened the .bat and it just gave me: Exception in thread "main" java.lang.NullPointerException at com.jpexs.decompiler.flash.gui.Main.clearTemp(Main.java:1591) at com.jpexs.decompiler.flash.gui.Main.main(Main.java:1606) I currently have installed version 7.1.2, I have also tried the nightly build (Doesn't work either.) Is there something I'm missing? If so, what else can I do to help fix this problem? I would like to know if there is a way to fix this that I haven't tried. Another thing I'd like to note, the decompiler has worked before and never gave me this error at all. In fact, this whole problem started more than a few weeks ago but before that, it worked. Please reply back, and thanks in advance.
Downloadhelp.jpg (87 KiB)
user
I forgot to also note that I have attempted to search solutions for this, but to no avail I found nothing.
admin
Could you please take the same screenshot of the exception in the current nightly build?
developer
http://stackoverflow.com/questions/20347161/listfiles-returns-null-when-it-shouldnt-it-use d-to-work-properly-until-recen listFiles: "runs fine with 64-bit-JRE and throws NullPointerException under 32-bit-JRE on Windows 7 64-bit." I'll add a null check.
user
Here is a picture of both .bat files open from the nightly build and version 7.1.2
developer
Did you download the latest nightly? There is no line 1801 in the latest nightly.
user
Ah well, that must have been an old version I had installed. I opened the newly installed nightly .exe file and it worked, .bat appears to take a while but the .exe works. The only thing I'm confused about now is how the nightly build works but the normal 7.1.2 doesn't. (I lack knowledge of java's inner coding..)
Downloadnightly.jpg (103 KiB)
developer
Ok, so this bug is fixed.
State: new→upgraded
developer
I close this issue due to inactivity. Please create new issue if problem still exists.
State: upgraded→closed
 
Google Translate: Translate to Czech Translate to Slovak Translate to Russian Translate to Hungarian Translate to Swedish Translate to French Translate to German Translate to Spanish Translate to Italian
Change style: oceanic classic