JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

+ update 2020: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means we will NOT develop new features and/or fix most of bugs. We left the tracker running in case somebody from community would like to work on it. Sorry for the inconvenience.

List of issuesList of issues

#1235 Parent Close Comma Error
Author: user rhp1989
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: AS3Direct Editation
State: new Help

> What steps will reproduce the problem? When I edit the actionscript inside the attached .swf file and try to save it I get error displayed in screenshot. The .swf file belongs to a android apk. > What is the expected output? What do you see instead? I am editing the actionscript so I can change upper values to add more content to the android apk but i keep getting this error and it won't let me save > What version of the product are you using? Is it "nightly build"? Which operating system do you have? version 8.0.1 on mac OS X Yosemite 10.10.5 > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you.
user
Hi I've tried nightly build on mac and windows and I still get the same error
user
hello bro i also have the same problem, with the same game
user
Developer~ We need your help :') <3 <3 <3 <3
admin
Sorry, I have no plans about fixing ActionScript direct editation errors. It's buggy - it's marked as experimental. You can make minor changes with P-code editation - the panel on the right side, which should be more error resistant.
user
any idea to fix this issues? been looking for answers if i must replace the comma with something. what should i do?