JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#1259 CTRL Click on AS3 Functions do not work anymore + question.
Author: user WindowsTV
Date created:
Type: bug
Visibility: Everybody read only
Assigned to:
State: closed Help

> What steps will reproduce the problem? When you hold down CTRL then click a Function or Variable it does not take you too it's place it's used/Declared. I'm not sure is it's disabled but can not find a setting for it. > What version of the product are you using? Is it "nightly build"? Which operating system do you have? version 8.0.1, Windows 8.1. I'm not sure which build had this feature. > Please provide any additional information below. I also have a question - The Import Script button, how does this work? Does it allow to import class files? If so I can't get it to work. If this is not a feature can it be? Thank you!
developer
Import script can import only the existing classes.. so if you export all/some scripts and edit those files, then you can import back the changes. (basically it is the same as editing the class in ffdec, open a class, edit, save, open the 2nd, edit save, ...) It is not possible to add/import new class/script files. We will check the 1st bug.
developer
About CTRL Click: for me it works, please try to reset your settings or try another SWF if it work with another SWF, then please attach your "wrong" SWF file
user
I've reset the settings and tried multiple other SWFs and still nothing. I've attached the SWF that I've used the CTRL Click the most on in before the update and it will not allow me in this version. It's an interesting SWF but ah-ha-ha yeah...
Downloadpuffle_care.swf (1,055 KiB)
admin
Please try version "9.0.0". I think it was fixed earlier in the nightly build.
State: new→upgraded
user
version "9.0.0" did fix the issue! Thank you! :)
admin
State: upgraded→closed