JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#1513 .swf.tmp problem
Date created:
Type: bug
Visibility: Everybody
Assigned to:
State: new Help

> What steps will reproduce the problem? 1.) In your app, I open my .swf game that i want to modify 2.) After I've done modifying, i click: 2.1) Save 2.2) Save as, and saved it as .swf 2.3) Save as Exe... (I feel like thats a longer name, yet i can't see it and i can't even stretch the pane to see the whole name, nor even putting in full size window. maybe that's a thing that needs also some fix) > What is the expected output? What do you see instead? I don't actually know what's actually the expected output in here as indication that i succeed saving, but according to what i see in other's closed but unsolved same issues, and some notable things i saw as i use your app/program, I assume that there should be a message that my attempt is successful, the same way how a message appears after i save my modified string in P-Source Code. I see instead the following: For 2.1- I saw a same name file with extention file ".swf.tmp" and no message appeared. Saved with 0 bytes For 2.2- The same thing. Also saved with 0 bytes. For 2.3- i put this here since the problem is similar, as the file only saves as .tmp file with 204kb only, though the swf file itself is 59.5 mb > What version of the product are you using? Is it "nightly build"? Which operating system do you have? Welp, its your latest stable version as of this date, v.11.2.0 > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you. 1.) Im using Windows 7 Ultimate 32-bit 2.) There's a very noticable lag in almost everytime i use the app, i guess: 2.1) This is kinda normal? Since the file im trying to modify is said to be obfuscated by the app (§§ thingy). Also: 2.2) This lag also happens as i do those 3 types of saves i said earlier, then eventually stops lagging, though without notifying me if it become successful. Both "save" and "save as" has a lag that stays somewhere between 13-15 seconds, and both done twice. that's 4 total attempts, with almost same lag interval. 3.) For the "save as exe...", At some reason avast recognize the .tmp file with an infected virus named "Win32:MalOb-LB [Cryp]" in every attempt (3 attempts). I also count the last attempt lag interval. Same in between 13-15 seconds. 4.) But this all doesn't mean that the problem will be always come from your side, the creators. It can be like incompatibility on my side, since my pc is kinda slow. That might also be the reason why it works fine when you try the app on your pc. 5.) I also wait after the lag interval, in case im just exaggerating. I confirm to you that the .swf.tmp file's size never moves/increases. Sorry for the long post, and thank you for your time. I'm really looking forward to use your app more in the near future
user
Here's btw the o byte size files i'm talking about, in case you need it. By order: 1.) using "save" 2.) using "save as" 3.) the original file, you could try and save it as .exe and see if avast reacts. I remember one time that the game, according to the creator of this one, was being detected by many antiviruses as infected, though he said that it must be just false positive that the code is somehow similar to how the specific virus is written. so ill put this one also here.
user
the third one:
user
oh, it seems my internet can't send the bigger file yet. Let me just know if you need also that file.
user
Update: I've tried another .swf game to modify. IT WORKS FLAWLESSLY GREAT. So i assume its on the obfuscation of the file??? Weird, since your decompiler reads it very fine. I'll send to use the file later when internet strikes fast.
user
welp, it seems i can't attach the file. on the other hand, i have a workaround, here's a link. google (and perhaps firefox) auto download the swf rather than playing it inside the browser, so it's like a download link. here: http://kupogames.com/wp-content/uploads/EBF5beta.swf
user
Update: I used "sothink swf decompiler". the program tried parsing the swf file, but after 90%, a message "the swf file is corrput" appears. I just put this here in case this information is useful.
user
Update: It turns out, this error "java.lang.OutOfMemoryError: java heap space" occurs when attempting to save this file using your jpex decompiler. I guess someone could help me here now pls. Also, I suggest adding a "an error occured, click the red x shield located at bottom-rightmost pane for log details" or something-like-that message that will appear to prompt us that there's an error occured, since not everyone has a keen eye to see that green √ changing into red x in that small particular place. Also again, im aware that this thread is almost like im talking to myself because of these consecutive long comments of mine lol xD.
user
Update: At long last! I found a solution that can be useful for other people who had the same problem before! Refer to this link for the solution: https://www.ghacks.net/2014/05/22/fix-error-create-java-virtual-machine-windows/ In my case, here'w what i do (i use windows 7): 1.)click start 2.)right click computer-- propeties 3.)click advanced system settings (you should be an admin to do this) 4.)select environmental variables. 5.)click on new under system variables. ---At this point the inputs you are about to do are case sensitive. So check the capitalization--- 6.)Enter _JAVA_OPTIONS as the variable name. 7.)Enter -Xmx###M as the variable value. (The number depends on your RAM, use either 1/2 or 1/4 of your actual RAM size (eg. if your RAM is 4Gb, use --Xmx2048M or -Xmx1024M) 8.)Click ok twice. Now there are 3 results to the Jpex decompiler: 1.) An error "Error: Could not create the Java Virtual Machine" appears -Solution: as i said, mind the capitalization since it's case-sensitive. 2.) Jpex's small loading-like box just quits immediately and the program didn't open. Re-opening the program will just repeat the immediate quit. -Explanation and Solution: i don't know why, but the decompiler just can't support higher heap space (like -Xmx2048M in my case). So do some trial and error what is the maximum capable heap space the jpex is able to open (in my case again, it's -Xmx1300M) 3.)It worked nornally finally, and no more .swf.tmp stuck up. PLUS! You might notice that the jpex decompiler becomes faster. That thing is also a positive side effect of this solution :D And for future problems (this if for the devs of jpex. This is because i love your this free powerful program): -Rather than asking for "how can i recreate the problem?" Statement, ask for the error log details. This is because every computer is not the same to each other, so at some point it works fine at high end PCs (eg. When you try to recreate the problem but no problems arised), but it doesn't work on low end PCs (which is in my case). May this self-long post, all created and solved by me, will be helpful for the future problems that may arise in this app/program. As i end, i declare this thread now as Closed. Good day to all of you :D