JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: The issue tracker is now writable again and logged users can download files too. But note that our support is very LIMITED.

List of issuesList of issues

#1678 Cannot preview some elements
Author: user STA20
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: Flash ViewerShapes
State: closed Help

> What is the expected output? What do you see instead? Shape 41 doesn't show, Shape 50 doesn't display correctly, and it seems all objects related to them fail to show - Button 42, 48, 57, Sprite 43, and the flash itself (which is an exported sprite). > What version of the product are you using? Is it "nightly build"? Which operating system do you have? Problem does not happen in v.14.1.0 and earlier. First spotted in v.14.3.1 stable and nightlies. > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you. If using external viewer, all items can be previewed, but still have empty thumbnails.
Downloadsprite81.swf (64 KiB)
admin
Please try nightly 1924, it should be better.
State: new→upgraded
user
I encountered same problem in the same intro taken from a different file (file attached). First tested on nightly 1924, then on 1925, there were some differences: 1924: Can't see Shape 39, Buttons 40 and 46, and only the preview of Button 55 and Sprite 79 (but they show if clicked). Flash can be previewed (but missing the button 40/shape 39 part). 1925: like 1924, but Sprite 79 and flash itself don't show. v.14.1.0 stable (tested for reference): Everything shows up, including thumbnails; Shapes look fine, but Sprite 41 and Button 46 are rendered incorrectly.
Downloadintro79.swf (91 KiB)
user
On the last attached file I also encountered an entirely different problem. If we try to remove this class (remove class.png), we get a spam of exeptions in the console log and FFdec becomes quite unstable, at least until we close the file (need to close it twice too). It still can be removed with no problem if we use this method (remove-safe.png).
admin
What do you mean "Can't see Shape 39" ? I can't reproduce it. Could you post a screenshot? I selected shapes/DefineShape4 (39) and it's there (see attachment). What's your zoom level/window size?
Downloadshape39.png (150 KiB)
admin
Please try nightly 1926, I did some changes, it might be related to the shapes/sprites problem.
user
Everything works perfect in 1926, thank you. That other thing with removing the class is still there though.
admin
The class removing is fixed in nightly 1927.
user
[v.14.4.0] Everything mentioned here works fine now. Thanks for the quick responses and bugfixes.
admin
You're welcome. I will possibly write to you later to reproduce the missing shapes (I still can't reproduce it on my PC). I disabled miter-join-clip feature because of this and that solved it. It seems that miter-join-clip feature is not working correctly and I'd like to fix it at some point in the future...
State: upgraded→closed