JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit

NEW : We have got a new blog where we post some interesting SWF internals info.

List of issuesList of issues

#1713 Re: #1395 Debug not working
Date created:
Type: bug
Visibility: Everybody
Assigned to:
State: opened Help

Hi. I'm not the OP, but this is a continuation of "#1395 Debug not working" / I tried loading an swf and debugging it, first with ffdec 11.2.0 which I had on hand, and then updated to 14.4.0 and tried again. Both times I hit the error mentioned in the linked issue. I reran version 14.40 with Java 16 to get a more detailed NPE, below: java.lang.NullPointerException: Cannot invoke "com.jpexs.decompiler.flash.SWF.isAS3()" because the return value of "com.jpexs.decompiler.flash.gui.MainPanel.getCurrentSwf()" is null at com.jpexs.decompiler.flash.gui.DebuggerHandler.connected( at com.jpexs.debugger.flash.Debugger$ From there, I took a look at MainPanel.getCurrentSwf() source on github, and I was able to deduce that you need to have an swf selected in the navigation tree to the left. Selecting the loaded swf on the left and then trying to debug again fixed the issue. I'm not sure if this is documented somewhere, but it was non-obvious to me. It may or may not be what the original poster of #1395 was running into. I would have liked to post on the original thread as well so that, until this is fixed, anybody else who ends up here via google will get a potentially helpful hint, but the issue is closed.
It seems to me that in current version (nightly 2132), maybe even in 16.0.4, I am unable to hit Debug button when there's no SWF selected. If the problem still occurs, please tell us how do you do that.
State: new→opened