JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: The issue tracker is now writable again and logged users can download files too. But note that our support is very LIMITED.

List of issuesList of issues

#1772 Decompiling Timeout / Stack Overflow
Author: user Shuckle
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: AS1/2Decompilation
State: new Help

> What steps will reproduce the problem? When attempting to decompile the "frame 3" action script from the swf file (ppswf.swf) without deobfuscation, the program receives a timeout error when setting the timeout to 1 minute, and the same error appeared when setting to 5 minutes. I tried it again with deobfuscation turned on, and I ended up getting really high RAM usage and a stack overflow error. The problem that I have is that in the SOTHINK Decompiler, it is able to decompile no problem. I tried decompiling through the JPEXS command line also, but the output was an empty file. Every other script was able to be decompiled except "frame 3" which is quite large compared to the others. Also, it seems like the P-Code was able to be disassembled but not the actionscript. > What is the expected output? What do you see instead? I expected to see the actionscript decompiled from the "frame 3" script, just like the image I provided from the SOTHINK decompiler, but it failed to produce any output. I attached images of all the errors (Stack Overflow, Timeout). > What version of the product are you using? Is it "nightly build"? Which operating system do you have? I am using v.15.0.0, and am on Windows 10. > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you.
user
Did you solve this issue?
admin
The script is huge and our decompiler is not very optimized for such large AS1/2 code. I think we are unable to optimize it such way. Our decompiler does many things regarding trying to bypass obfuscations and other problems, but such things cannot be done on such large scale. Sothink works differently and can handle this on clean code. But with obfuscation, it will fail. Sorry, but I don't see this working in near future if ever...
user
Is it possible to decompile and edit such a large file? All the other software I've seen runs out of memory before being able to. Is there no way of splitting it into smaller, more manageable steps?
user
Hi, I ended up just decompiling it on Sothink successfully after buying it. I haven't bothered to edit it on Sothink either cause I got banned from the game for botting anyway. But thanks for the reply and for all your hard work and effort.