JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: The issue tracker is now writable again and logged users can download files too. But note that our support is very LIMITED.

List of issuesList of issues

#1821 multiple DoAation Tag not applied to frame correctly
Author: user aiglove
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: AS1/2
State: opened Help

> What steps will reproduce the problem? download the swf file from here or attachment: http://web.archive.org/web/20080912011126/http://www.atlus.co.jp/cs/game/pstation2/persona4/nozoki/ (this game looks like can not run correctly but this is not the key point) open in ffdec, switch to hex dump, you can see there's 2 DoAction before first ShowFrame switch back to Resources, check scripts in first frame, the first DoAction's script not included > What is the expected output? What do you see instead? first DoAction's script should included > What version of the product are you using? Is it "nightly build"? Which operating system do you have? v 15.1.0 stable , windows 10.0.19041.450 > Please provide any additional information below. If the problem is related to a SWF file, attach it here, otherwise we can't help you.
Downloadnozoki.swf (2,423 KiB)
user
sorry I mistook with the tags, but the issue still, here's updated information > What steps will reproduce the problem? download the swf file from here or attachment: http://web.archive.org/web/20080912011126/http://www.atlus.co.jp/cs/game/pstation2/persona4/nozoki/ (this game looks like can not run correctly but this is not the key point) open in ffdec, switch to hex dump, you can see there's a DoAction and it's content switch back to Resources, check scripts in first frame, most parts the first DoAction's script was not included > What is the expected output? What do you see instead? all script should included > What version of the product are you using? Is it "nightly build"? Which operating system do you have? v 15.1.0 stable , windows 10.0.19041.450
user
after some digging its looks like something broken in this swf file, even you can see those scripts in hex, the official swf player ignored those scripts also, sorry to wasted your time to whoever read this, please close this issue.
admin
I don't see a problem in this file. Maybe you have "Automatic deobfuscation" enabled? In such case, the decompiler hides few things from the script.
State: new→opened