JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit

NEW : We have got a new blog where we post some interesting SWF internals info.

List of issuesList of issues

#1952 jpex crash when searching memory
Author: user mmrr4
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: Memory search
State: new Help

JPEX crashes again when searching in memory, this was fixed before but now since the last update its still there
PS: it works on latest nightly version
So in which version it does not work? 18.3.3 ? And nightly 2448 or later works?
In the latest version it does not works (version 18.3.3) in the latest nightly it does work.
Ok, I have some more questions. a) Can I reproduce it somehow? I tried to load a game in the flash player projector and then search memory in it (with version 18.3.3) and it worked for me (no crashing). We did not do any special changes regarding memory search in the current nightly builds. b) It might be SWF related (?), could you add sample SWF file you try it on? c) What operating system do you have? d) Which moment does it crash? Is is after doubleclicking the EXE name (clicking "Select button") when it searches, or after clicking the result in the table?
It crashes when double clicking on the process it loads some swf files but then almost at the end it crashes. this happened before too but got fixed now I tried the latest version (not nightly) and it crashes again / ry Add an auto report system when the app crashes it sends logs with the exception to you. This is what I did 1. Opened the Game 2. Clicked on Search memory and then selected the game 3. It loads all swf files in the table but not fully 4. at progress 80% or something it crashed.
I think you need to provide some more information: - What is your operating system? - What program/game are you searching the memory of? Also, does the problem only occur when searching the memory of this specific game? Can you try opening a simple SWF in the Adobe Flash projector and searching its memory?