List of issuesList of issues

#570 Direct AS3 Edition bug
Date created:
Type: bug
Visibility: Everybody
Assigned to: admin JPEXS
Labels: AS3Direct Editation
State: closed Help

> What steps will reproduce the problem? Just trying to save a direct AS3 edition > What is the expected output? What do you see instead? Nothing. > What version of the product are you using? On what operating system? 2.1.0 > Please provide any additional information below. Attach the file you have problem with if neccessary. If you do not want to publish files YOU CAN CHANGE VISIBILITY TO PRIVATE So, i was decompiling a SWF, i tried to change the script using direct AS3 edition and it didn't work at saving. I'm really sad about this bug... I worked hard on that script and it didn't save. I tried again and it didn't work. Nothing appears on output, wich is weird, but i tried to go to script again and i even tried the swf and nothing happend. It simply didn't save.
Downloadee2_v94.swf (4,072 KiB)
admin
Which class?
admin
Which script are you trying to edit? What do you mean by "didn't work at saving". Is there any error message? We need you to be more specific. "Doesn't work" is not really helpful bug report. Thanks.
user
Well, i tried to edit Configure script. Also, it doesn't show a error message, but when i go back to it, it didn't save my changes.
admin
Version 2.1.0u1 released, it should be better now, try it.
State: new→upgraded
Assigned:admin JPEXS
user
I''m getting something similar to this, whenever I try to save action script through direct as edit I get this error (SEMICOLON expected but MINUS found on line 39) Line 39 contains this: import _-1C.FindUser; Can you stop that error, ignore it or add an option/tickbox to ignore it?
developer
Fable: "_-1C" is not a valid identifier name. Your swf should be obfuscated. So the error message is correct. You can't write mathematical expressions after input keyword.
developer
*input = import:)
admin
You can try renaming invalid identifiers first. See Deobfuscation menu. I am closing this if you don't mind.
State: upgraded→closed
 
Google Translate: Translate to Czech Translate to Slovak Translate to Russian Translate to Hungarian Translate to Swedish Translate to French Translate to German Translate to Spanish Translate to Italian
Change style: oceanic classic