: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#574 Crash after editing scripts
Date created:
Type: bug
Visibility: Everybody
Assigned to:
State: invalid Help

> What steps will reproduce the problem? trying to run the SWF after editing any script > What is the expected output? What do you see instead? Nothing, somehow. I just see a crash after trying to run the SWF > What version of the product are you using? On what operating system? 2.1.0u1 > Please provide any additional information below. Attach the file you have problem with if neccessary. If you do not want to publish files YOU CAN CHANGE VISIBILITY TO PRIVATE After i edit a script, as in AS3 or TRAITS, when i try to run the SWF the SWF dissapears. Even if i turn things back to normal! Please help
admin
hmm, that's bad, but... Where is your SWF file? We can't fix the problem without seeing it. Please attach the original unmodified file here and tell us which scripts you try to modify and how.
admin
Visibility: Everybody→Developers only
developer
Visibility: Developers only→Developers only
admin
megalol: Thanks for reporting, but next time, please, create new issue. This one is about AS3 editing. For the DefineSprite problem: It's fixed in the repository, I will release nightly soon and maybe update 2.
admin
megalol: update 2 was released, DefineSprite problems should be fixed realmaster42: I made some changes in direct editation in update 2, but I don't know wheter it helps you with this issue. We need the SWF file to test it.
admin
I moved megalols issue to #576 and made this public again.
Visibility: Developers only→Everybody
user
I tried editing every other script in many different SWFs and it caused the same. Hope next update has this fixed
admin
Yes, then give us at least one SWF which "causes the same". We don't have it. SWFs I tried work.
user
I will download the newest version then
admin
State: new→invalid
 
Google Translate: Translate to Czech Translate to Slovak Translate to Russian Translate to Hungarian Translate to Swedish Translate to French Translate to German Translate to Spanish Translate to Italian
Change style: oceanic classic