JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#629 Program won't start under Windows or Linux
Author: user Mateon1
Date created:
Type: bug
Visibility: Everybody
Assigned to:
Labels: Installation
State: closed Help

> What steps will reproduce the problem? Run the decompiler executable/Run the .jar file > What is the expected output? What do you see instead? Expected to see the program launch. On Windows nothing happens, on Linux this error comes up: Aug 02, 2014 3:38:59 PM com.jpexs.decompiler.flash.gui.Main initLang SEVERE: null java.lang.ClassNotFoundException: org.pushingpixels.substance.api.SubstanceLookAndFeel at java.net.URLClassLoader$1.run(URLClassLoader.java:372) at java.net.URLClassLoader$1.run(URLClassLoader.java:361) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:360) at java.lang.ClassLoader.loadClass(ClassLoader.java:426) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:317) at java.lang.ClassLoader.loadClass(ClassLoader.java:359) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:264) at com.jpexs.decompiler.flash.gui.Main.initLang(Main.java:770) at com.jpexs.decompiler.flash.gui.Main.main(Main.java:877) Exception in thread "main" java.lang.NoClassDefFoundError: org/pushingpixels/substance/api/skin/SubstanceOfficeBlue2007LookAndFeel at com.jpexs.decompiler.flash.gui.View.setLookAndFeel(View.java:124) at com.jpexs.decompiler.flash.gui.Main.initGui(Main.java:726) at com.jpexs.decompiler.flash.gui.Main.main(Main.java:886) Caused by: java.lang.ClassNotFoundException: org.pushingpixels.substance.api.skin.SubstanceOfficeBlue2007LookAndFeel at java.net.URLClassLoader$1.run(URLClassLoader.java:372) at java.net.URLClassLoader$1.run(URLClassLoader.java:361) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:360) at java.lang.ClassLoader.loadClass(ClassLoader.java:426) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:317) at java.lang.ClassLoader.loadClass(ClassLoader.java:359) ... 3 more > What version of the product are you using? On what operating system? Using the latest version (2.1.2), the bug occurs both on Windows when running the executables and on Linux when using "java -jar -Xmx1024 ffdec.jar" The stacktrace of the error on Linux is in the "What do you see instead?" part. > Please provide any additional information below. Attach the file you have problem with if neccessary. If you do not want to publish files YOU CAN CHANGE VISIBILITY TO PRIVATE Windows 7 with JRE8 Arch Linux with JRE7 Arch Linux with JRE9 (Both give the same error)
user
Sorry, didn't fill the title, if some admin comes by please change the title to "Program won't start under Windows or Linux"
developer
Title: →Program won't start under Windows or Linux
developer
Do you have the following files in the FFDec fodler/lib folder? flamingo-6.2.jar substance-6.2.jar substance-flamingo-6.2.jar
user
Yes, I have all of those files
user
I downloaded the .ZIP file, the same happens if I use the installer, I don't see any error since no console is open but nothing happens, the program doesn't open.
developer
Strange... i do not have similar problem... at least on Windows:( please could you execute the following command in a command prompt when you are in ffdec folder? dir /s >dir.txt then please attach the result "dir.txt"
user
Here's the file.
Downloaddir.txt (3 KiB)
user
Also, could we talk on some IRC or on Skype? This issue comment process is too slow, I get emails half an hour late if not later. We have too much comment delay. My Skype is mateusz_nasciszewski and I can talk on any IRC.
user
Nevermind, the issue is now suddenly fixed, I ran java -jar ffdec.jar --debug It didn't work the first time but when I opened ffdec64.exe the next time it suddenly worked! This issue can now be closed. I'm having other problems now though, whenever I click something that opens up Flash Player it opens up a popup "Klasa niezarejestrowana" [Class unregistered] and hangs the program. I can't click shapes, frames, and possibly other things I didn't try yet, only scripts work from what I've tried so far. Anyway, that is another issue, this can be closed.
developer
Ok, i added you on Skype. I'll close this isse. JPEXS: Please remove Mateon1's Skype name from this page, when you are back from your journey.
State: new→closed