JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#733 JavactiveX output not being captured?
Author: user CyberFoxx
Date created:
Type: bug
Visibility: Everybody
Assigned to: admin JPEXS
Labels: External Viewer
State: closed Help

> What steps will reproduce the problem? Load up any SWF with recent 4.x versions of FFDec Either click on the main SWF or any subitems (sprites, shapes, etc) > What is the expected output? What do you see instead? I expect being able to see the what I clicked on. Instead all I get is a blank frame where the item is supposed to show up. > What version of the product are you using? On what operating system? Tried with multiple releases of the 4.x series. (AKA: Ever since the change to the JavactiveX library) Windows Server 2008 R2 Enterprise 64-bit ActiveX Flash 15.0.0.239 > Please provide any additional information below. Attach the file you have problem with if neccessary. If you do not want to publish files YOU CAN CHANGE VISIBILITY TO PRIVATE The javactivex_(random number here) process gets spawned, and uses CPU, but it doesn't seem to have it's output captured by the main FFdec process. I've tried with both the ribbon and "classic" UI style. The only way to get any output is to "use own flash player" or go back to a 3.x version of FFdec. This happens with _any_ SWF file. Attached are the console output from running the ffdec.bat file, and the log file generated when loading up a simple clock swf ( http://www.flash-test.net/ ) I found on the net. (I think I had debug console output on, not sure...)
admin
In older(working) version, do you have "SWF preview" or "SWF preview (Internal viewer)" caption on top of the SWF panel? Is the ActiveX really working in older version? Try rightclick the SWF preview if there is a menu.
user
It says "SWF preview" in the older working version, and I do get the Adobe Flash right-click menu. (Sadly, bringing up the menu seems to cause the Flash ActiveX to crash at that point) Also, after doing more testing I noticed something weird when I swapped back to the 3.0.0 release, I had to set the compatibility mode on the "FlashPlayer.exe" to "Windows 7". Otherwise I would get a "Invalid Access to Memory Location" from FFdec and "Access Violation at address 0045F037 in module 'FlashPlayer.exe'. Read of address 00000000." from the "FFDec Flash Player". I remember having an error like that happen before with another program, so that's why I tried setting the compatibility mode to "Windows 7" on the "FlashPlayer.exe" file. Maybe the same thing is happening with the javactivex binary? Looks like it is. I changed the compatibility setting on the FFdec.exe and FFdec64.exe files to "Windows 7" (Because the compatibility setting is inherited by child processes) and now it works with the latest 4.0.4 release. (Also, the Flash ActiveX doesn't crash on the right-click anymore.) Just wish I could remember exactly what the reason I had to change the compatibility setting on that other program was. I think it had to do with a recent Windows Update, but can't exactly remember. Anyway, version 4.0.4 seems to be working now with it set to "Windows 7" compatibility. *Shrug* Maybe make a note of that just in case someone else runs into it? (I recall it was an update for only the Windows Server 2008 series)
admin
I improved the JavactiveX library few versions ago. Do you have problems with the Flash now?
State: new→upgraded
Assigned:admin JPEXS
developer
It was fixed more than 1 month ago, I close this issue due to inactivity. Please create new issue if the problem still exists.
developer
State: upgraded→closed