JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#909 text editig problem
Author: user cspyder
Date created:
Type: question
Visibility: Everybody
Assigned to:
Labels: Text
State: closed Help

After I edit some text on a swf/fla file, it becomes obfuscated, with no spacing between letters and obviously unreadable. Is there something I'm doing wrong? Please help. Thank you.
developer
Please attach your swf file, and specify what do you change. (Also specify the new text if it is relevant)
user
I'm attaching the corresponding file, which is a client's website. There are several text changes, but one that I tried to do was update the copyright date on the bottom of all pages, which is labeled as: "Define Text (599)" Thank you
Downloadmain_flash8.swf (1,271 KiB)
developer
The font in your swf has no layout information. So ffdec tries to get the values from system fonts. And probably your system has no installed "standard 07_53" font. (Definefont3 (143)) So FFDec uses the values from the default fallback font, which is Times New Roman. You can specify another system font for this swf font. Just select DefineFont3 (143) in the left tree, then change the selected value in the Source font dropdown.
State: new→upgraded
user
Thanks for your prompt response. I have attempted to do what you said above, and have indicated with red arrows on the attached picture as to where I think the change should be, but shouldn't that font be "standard 07_53"?, which is not in the dropdown menu. How would I know what exactly "standard 07_53" font is, so that I can find it within the dropdown menu? or am I doing it backwards? Thanks again for your help.
Downloadjpex_pic2.jpg (176 KiB)
developer
If standard 07_53 would be in the list, it would works automatically... You should try to find a similar font manually... So select 1st font, check the result, etc... Sorry, but I don't have any better idea.... maybe you can find this font on the internet, and install it as a system font.
developer
I downloaded this: http://www.fonts2u.com/standard-07-53.font And it looks good now.
developer
Font attached.
Downloadstan0753.ttf (25 KiB)
user
Sorry to keep bothering you about this issue, but the only place where I could find to upload the tiff file is under the "embed" button, while under the "Define Font3 (143)mode. However, it doesn't show anywhere after that. Please let me know where to go within the program to upload the file. Thank you
admin
Well, you can install it in your OS for example... (Maybe right click in Windows and Install?)
user
Thank you so much for your help. Everything worked perfect! Will recommend to all my friends. Keep up the good work! Cheers
developer
You're welcome
State: upgraded→closed