JPEXS Free Flash Decompiler Issue Tracker

If you are looking for the decompiler itself, visit https://github.com/jindrapetrik/jpexs-decompiler

: WARNING - support of the decompiler is now VERY LIMITED. There are no active developers. This means waiting times in the issue tracker are very long and mostly depend on community. Sorry for the inconvenience.

List of issuesList of issues

#97 FFDec asks for Java 1.6.0
Author: user kuro
Date created:
Type: other
Visibility: Everybody
Assigned to:
Labels: Installation
State: closed Help

I've just downloaded the zip file of ffdec 1.6.0 but when I double click on the exe file (even as administrator) it return me the following message: This application requires Java Runtime Enviroment 1.6.0 and lead me on Java download page. I've tried to reinstall Java without success. I tried and old version I had and worked fine (ffdec 1.5.0u1).
DownloadJava.jpg (12 KiB)
admin
Which version of Java do you have? 32bit or 64bit? Please install the other one or install both.
State: new→opened
user
Installed both Version 7 Update 21 (x86 and x64) and rebboted the computer but still getting the message. (I'm on Windows 7 x64)
admin
1) Move ffdec to writable folder (not program files) 2) Run ffdec.exe with parameter --l4j-debug From commandline: ffdec.exe --l4j-debug 3) Attach generated launch4j.log file here Thank you.
user
Here is the log.
Downloadlaunch4j.log (500 B)
admin
4) Please open registry editor. - Go to start menu - To search field, enter "regedit.exe", press enter 5) In the left tree, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\ 6) Export that branch via menu "File->Export". 7) Attach the .reg file here Thank you
user
reg for you.
DownloadJRE.reg (2 KiB)
admin
There is a strange key "1.7u3". Do you have other java than "1.7.0 update 21" installed? Please go to Control panel -> Add or remove programs and check if there are more Javas. Thank you.
user
No I don't have other java, only Java 7 update 21 and Java 7 update 21 (64-bit), could it due to the fact that I had the bad idea of restore windows using the default System Restore some times ago?
admin
Please doubleclick attached REG file. It will fix JRE registry so the EXE should work. I don't know how this situation arised. My colleague tells me it could be caused by automatic java updater which sometimes messes the things up.
DownloadJREfix.reg (412 B)
user
It worked :) Thank you.
admin
You are welcome.
State: opened→closed